re = /<<(?>(?>[^\\>]*)(?>>(?!>))?)*+\\(?>(?>[^>]*)(?>>(?!>))?)++>>/
str = 'Account number: <<@Account.AccountNumber>>
<<@Am\\hich\\af1\\dbch\\af31505\\loch\\f1 ount>>
<<@Amount>>
<<Where: Phrase =\\ @Value>>\\<<hi>>\\hi<<hi>>
<<\\hich\\af1\\dbch\\af31505\\loch\\f1 @Amount>>
<<@Amount\\hich\\af1\\dbch\\af31505\\loch\\f1 >>
<<Where: Column > Value>>
<<Where: Column\\hich\\af1\\dbch\\af31505\\loch\\f1 > Value>>
<<Where: Column > \\hich\\af1\\dbch\\af31505\\loch\\f1 Value>>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end