# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/{{showcase_small\("([^"]+)"\)}}/$showcase->classyBox("${1}")/;t' <<< "{{showcase_small(\"classy_box\")}}"