use strict;
my $str = '{{showcase_small("classy_box")}}';
my $regex = qr/{{showcase_small\("([^"]+)"\)}}/p;
my $subst = '$showcase->classyBox("${1}")';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";