$re = '/{{showcase_small\("([^"]+)"\)}}/';
$str = '{{showcase_small("classy_box")}}';
$subst = "$showcase->classyBox(\"${1}\")";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;