re = /{{showcase_small\("([^"]+)"\)}}/
str = '{{showcase_small("classy_box")}}'
subst = '$showcase->classyBox("${1}")'
result = str.sub(re, subst)
# Print the result of the substitution
puts result