const regex = /{{showcase_small\("([^"]+)"\)}}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{{showcase_small\\("([^"]+)"\\)}}', '')
const str = `{{showcase_small("classy_box")}}`;
const subst = `$showcase->classyBox("${1}")`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);