#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:(?:ht|f)tps?:\/\/|www)[^\s,?!]+(?!.*<\/a>))"
Local $sString = "http://www.example.com" & @CRLF & _
"http://www.example.com/test" & @CRLF & _
"http://example.com/test" & @CRLF & _
"www.example.com/test" & @CRLF & _
"https://www.example.com" & @CRLF & _
"<a href="http://www.example.com">http://www.example.com </a>" & @CRLF & _
"<a href="http://www.example.com/test">http://www.example.com/test </a>" & @CRLF & _
"<a href="http://example.com/test">http://example.com/test </a>" & @CRLF & _
"<a href="www.example.com/test">www.example.com/test </a>" & @CRLF & _
"<a href="www.example.com/test"><img src="www.example.com/test,jpg" /></a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")