using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:(?:ht|f)tps?:\/\/|www)[^\s,?!]+(?!.*<\/a>))";
string input = @"http://www.example.com
http://www.example.com/test
http://example.com/test
www.example.com/test
https://www.example.com
<a href=""http://www.example.com"">http://www.example.com </a>
<a href=""http://www.example.com/test"">http://www.example.com/test </a>
<a href=""http://example.com/test"">http://example.com/test </a>
<a href=""www.example.com/test"">www.example.com/test </a>
<a href=""www.example.com/test""><img src=""www.example.com/test,jpg"" /></a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}