import Foundation
let pattern = #"((?:(?:ht|f)tps?:\/\/|www)[^\s,?!]+(?!.*<\/a>))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://www.example.com
http://www.example.com/test
http://example.com/test
www.example.com/test
https://www.example.com
<a href="http://www.example.com">http://www.example.com </a>
<a href="http://www.example.com/test">http://www.example.com/test </a>
<a href="http://example.com/test">http://example.com/test </a>
<a href="www.example.com/test">www.example.com/test </a>
<a href="www.example.com/test"><img src="www.example.com/test,jpg" /></a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)