const regex = /((?:(?:ht|f)tps?:\/\/|www)[^\s,?!]+(?!.*<\/a>))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:(?:ht|f)tps?:\\\/\\\/|www)[^\\s,?!]+(?!.*<\\\/a>))', 'gm')
const str = `http://www.example.com
http://www.example.com/test
http://example.com/test
www.example.com/test
https://www.example.com
<a href="http://www.example.com">http://www.example.com </a>
<a href="http://www.example.com/test">http://www.example.com/test </a>
<a href="http://example.com/test">http://example.com/test </a>
<a href="www.example.com/test">www.example.com/test </a>
<a href="www.example.com/test"><img src="www.example.com/test,jpg" /></a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}