# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:(?:ht|f)tps?:\/\/|www)[^\s,?!]+(?!.*<\/a>))"
test_str = ("http://www.example.com\n"
"http://www.example.com/test\n"
"http://example.com/test\n"
"www.example.com/test\n"
"https://www.example.com\n"
"<a href=\"http://www.example.com\">http://www.example.com </a>\n"
"<a href=\"http://www.example.com/test\">http://www.example.com/test </a>\n"
"<a href=\"http://example.com/test\">http://example.com/test </a>\n"
"<a href=\"www.example.com/test\">www.example.com/test </a>\n"
"<a href=\"www.example.com/test\"><img src=\"www.example.com/test,jpg\" /></a>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.