use strict;
my $str = 'http://www.example.com
http://www.example.com/test
http://example.com/test
www.example.com/test
https://www.example.com
<a href="http://www.example.com">http://www.example.com </a>
<a href="http://www.example.com/test">http://www.example.com/test </a>
<a href="http://example.com/test">http://example.com/test </a>
<a href="www.example.com/test">www.example.com/test </a>
<a href="www.example.com/test"><img src="www.example.com/test,jpg" /></a>';
my $regex = qr/((?:(?:ht|f)tps?:\/\/|www)[^\s,?!]+(?!.*<\/a>))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}