re = /((?:(?:ht|f)tps?:\/\/|www)[^\s,?!]+(?!.*<\/a>))/m
str = 'http://www.example.com
http://www.example.com/test
http://example.com/test
www.example.com/test
https://www.example.com
<a href="http://www.example.com">http://www.example.com </a>
<a href="http://www.example.com/test">http://www.example.com/test </a>
<a href="http://example.com/test">http://example.com/test </a>
<a href="www.example.com/test">www.example.com/test </a>
<a href="www.example.com/test"><img src="www.example.com/test,jpg" /></a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end