using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"background-color:\s(?:""(.+)""|(?!url)(\w+)|url\(.+\) (.+?)\s)";
string input = @"background: ""green""
background: url(""big_green.png"")
background: green url(""big_green"") no-repat
background: url(""big_green"") green no-repeat
background-color: ""#fff""
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}