$re = '/background-color:\s(?:"(.+)"|(?!url)(\w+)|url\(.+\) (.+?)\s)/';
$str = 'background: "green"
background: url("big_green.png")
background: green url("big_green") no-repat
background: url("big_green") green no-repeat
background-color: "#fff"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);