re = /background-color:\s(?:"(.+)"|(?!url)(\w+)|url\(.+\) (.+?)\s)/
str = 'background: "green"
background: url("big_green.png")
background: green url("big_green") no-repat
background: url("big_green") green no-repeat
background-color: "#fff"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end