use strict;
my $str = 'background: "green"
background: url("big_green.png")
background: green url("big_green") no-repat
background: url("big_green") green no-repeat
background-color: "#fff"
';
my $regex = qr/background-color:\s(?:"(.+)"|(?!url)(\w+)|url\(.+\) (.+?)\s)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}