import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "background-color:\\s(?:\"(.+)\"|(?!url)(\\w+)|url\\(.+\\) (.+?)\\s)";
final String string = "background: \"green\"\n"
+ "background: url(\"big_green.png\")\n"
+ "background: green url(\"big_green\") no-repat\n"
+ "background: url(\"big_green\") green no-repeat\n"
+ "background-color: \"#fff\"\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}