import Foundation
let pattern = #"background-color:\s(?:"(.+)"|(?!url)(\w+)|url\(.+\) (.+?)\s)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
background: "green"
background: url("big_green.png")
background: green url("big_green") no-repat
background: url("big_green") green no-repeat
background-color: "#fff"
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)