#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "{{#each\s(\w*\s)in\s(\w*)}}"
Local $sString = "{{#each item in model}} kldnmflk sdjkn" & @CRLF & _
"{{#each item in model}} l;dfmgk;s" & @CRLF & _
";d'sl,g" & @CRLF & _
"dsd" & @CRLF & _
"{{#each item in model}}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")