import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{#each\\s(\\w*\\s)in\\s(\\w*)\\}\\}";
final String string = "{{#each item in model}} kldnmflk sdjkn\n"
+ "{{#each item in model}} l;dfmgk;s\n"
+ ";d'sl,g\n"
+ "dsd\n"
+ "{{#each item in model}}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}