using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{{#each\s(\w*\s)in\s(\w*)}}";
string input = @"{{#each item in model}} kldnmflk sdjkn
{{#each item in model}} l;dfmgk;s
;d'sl,g
dsd
{{#each item in model}}";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}