const regex = /{{#each\s(\w*\s)in\s(\w*)}}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{{#each\\s(\\w*\\s)in\\s(\\w*)}}', '')
const str = `{{#each item in model}} kldnmflk sdjkn
{{#each item in model}} l;dfmgk;s
;d'sl,g
dsd
{{#each item in model}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}