import re
regex = re.compile(r"{{#each\s(\w*\s)in\s(\w*)}}")
test_str = ("{{#each item in model}} kldnmflk sdjkn\n"
"{{#each item in model}} l;dfmgk;s\n"
";d'sl,g\n"
"dsd\n"
"{{#each item in model}}")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")