re = /{{#each\s(\w*\s)in\s(\w*)}}/
str = '{{#each item in model}} kldnmflk sdjkn
{{#each item in model}} l;dfmgk;s
;d\'sl,g
dsd
{{#each item in model}}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end