# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<br)\b[^>]*?(?= *\\/?>)/\1/gm;t' <<< "<br id=\"foo\" style=\"display:none\">
<spam id=\"bar\">sometext</span>
<br id=\"bun\" />"