use strict;
my $str = '<br id="foo" style="display:none">
<spam id="bar">sometext</span>
<br id="bun" />';
my $regex = qr/(<br)\b[^>]*?(?= *\/?>)/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";