re = /(<br)\b[^>]*?(?= *\/?>)/m
str = '<br id="foo" style="display:none">
<spam id="bar">sometext</span>
<br id="bun" />'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result