$re = '/(<br)\b[^>]*?(?= *\/?>)/m';
$str = '<br id="foo" style="display:none">
<spam id="bar">sometext</span>
<br id="bun" />';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;