const regex = /(<br)\b[^>]*?(?= *\/?>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<br)\\b[^>]*?(?= *\\\/?>)', 'gm')
const str = `<br id="foo" style="display:none">
<spam id="bar">sometext</span>
<br id="bun" />`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);