#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(<br)\b[^>]*?(?= *\/?>)"
Local $sString = "<br id="foo" style="display:none">" & @CRLF & _
"<spam id="bar">sometext</span>" & @CRLF & _
"<br id="bun" />"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)