using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<br)\b[^>]*?(?= *\/?>)";
string substitution = @"\1";
string input = @"<br id=""foo"" style=""display:none"">
<spam id=""bar"">sometext</span>
<br id=""bun"" />";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}