using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=name=A_)([^\_]+)_([^\_]+)_([^\_]+)_([^\_]+)";
string input = @"http://www.test.com/?name=A_B_C_D_E_F&gclid=something
http://www.test.com/?name=A_first_second_third_fourth_fifth&gclid=something";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}