$re = '/(?<=name=A_)([^\_]+)_([^\_]+)_([^\_]+)_([^\_]+)/im';
$str = 'http://www.test.com/?name=A_B_C_D_E_F&gclid=something
http://www.test.com/?name=A_first_second_third_fourth_fifth&gclid=something';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);