import re
regex = re.compile(r"(?<=name=A_)([^\_]+)_([^\_]+)_([^\_]+)_([^\_]+)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("http://www.test.com/?name=A_B_C_D_E_F&gclid=something\n"
"http://www.test.com/?name=A_first_second_third_fourth_fifth&gclid=something")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")