re = /(?<=name=A_)([^\_]+)_([^\_]+)_([^\_]+)_([^\_]+)/im
str = 'http://www.test.com/?name=A_B_C_D_E_F&gclid=something
http://www.test.com/?name=A_first_second_third_fourth_fifth&gclid=something'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end