const regex = /(?<=name=A_)([^\_]+)_([^\_]+)_([^\_]+)_([^\_]+)/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=name=A_)([^\\_]+)_([^\\_]+)_([^\\_]+)_([^\\_]+)', 'img')
const str = `http://www.test.com/?name=A_B_C_D_E_F&gclid=something
http://www.test.com/?name=A_first_second_third_fourth_fifth&gclid=something`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}