import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=name=A_)([^\\_]+)_([^\\_]+)_([^\\_]+)_([^\\_]+)";
final String string = "http://www.test.com/?name=A_B_C_D_E_F&gclid=something\n"
+ "http://www.test.com/?name=A_first_second_third_fourth_fifth&gclid=something";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}