using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\<p><strong>Static text(.*)<\/strong><\/p>(.*)";
string input = @"<p><strong>Static text here</strong></p>
<p><img src=""test.png"">Here's an image</p>
<p>another example</p>c";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}