const regex = /\<p><strong>Static text(.*)<\/strong><\/p>(.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\<p><strong>Static text(.*)<\\\/strong><\\\/p>(.*)', 'g')
const str = `<p><strong>Static text here</strong></p>
<p><img src="test.png">Here's an image</p>
<p>another example</p>c`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}