package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\<p><strong>Static text(.*)<\/strong><\/p>(.*)`)
var str = `<p><strong>Static text here</strong></p>
<p><img src="test.png">Here's an image</p>
<p>another example</p>c`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}