re = /\<p><strong>Static text(.*)<\/strong><\/p>(.*)/
str = '<p><strong>Static text here</strong></p>
<p><img src="test.png">Here\'s an image</p>
<p>another example</p>c'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end