$re = '/\<p><strong>Static text(.*)<\/strong><\/p>(.*)/';
$str = '<p><strong>Static text here</strong></p>
<p><img src="test.png">Here\'s an image</p>
<p>another example</p>c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);