// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\<p><strong>Static text(.*)<\/strong><\/p>(.*)").unwrap();
let string = "<p><strong>Static text here</strong></p>
<p><img src=\"test.png\">Here's an image</p>
<p>another example</p>c";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}