import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\<p><strong>Static text(.*)<\\/strong><\\/p>(.*)";
final String string = "<p><strong>Static text here</strong></p>\n"
+ "<p><img src=\"test.png\">Here's an image</p>\n"
+ "<p>another example</p>c";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}