#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\"([^\"]*)\":\s*('[^']*'|\"[^\"]*\"|[+\-]?\d+(?:.\d+)?)"
Local $sString = "define({" & @CRLF & _
" "key1": "some text: and more"," & @CRLF & _
" "KeyA": ["Elem1", "Elem2"]" & @CRLF & _
" key2 : 'some text '," & @CRLF & _
" key3: ": more some text"," & @CRLF & _
" key4: 'some text:'," & @CRLF & _
" key5: 1998," & @CRLF & _
" key6: +45.122," & @CRLF & _
" key7: -33," & @CRLF & _
"});"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")