import Foundation
let pattern = #"\"([^\"]*)\":\s*('[^']*'|\"[^\"]*\"|[+\-]?\d+(?:.\d+)?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
define({
"key1": "some text: and more",
"KeyA": ["Elem1", "Elem2"]
key2 : 'some text ',
key3: ": more some text",
key4: 'some text:',
key5: 1998,
key6: +45.122,
key7: -33,
});
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)