$re = '/\"([^\"]*)\":\s*(\'[^\']*\'|\"[^\"]*\"|[+\-]?\d+(?:.\d+)?)/';
$str = 'define({
"key1": "some text: and more",
"KeyA": ["Elem1", "Elem2"]
key2 : \'some text \',
key3: ": more some text",
key4: \'some text:\',
key5: 1998,
key6: +45.122,
key7: -33,
});';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);