use strict;
my $str = 'define({
"key1": "some text: and more",
"KeyA": ["Elem1", "Elem2"]
key2 : \'some text \',
key3: ": more some text",
key4: \'some text:\',
key5: 1998,
key6: +45.122,
key7: -33,
});';
my $regex = qr/\"([^\"]*)\":\s*('[^']*'|\"[^\"]*\"|[+\-]?\d+(?:.\d+)?)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}