using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""([^\""]*)\"":\s*('[^']*'|\""[^\""]*\""|[+\-]?\d+(?:.\d+)?)";
string input = @"define({
""key1"": ""some text: and more"",
""KeyA"": [""Elem1"", ""Elem2""]
key2 : 'some text ',
key3: "": more some text"",
key4: 'some text:',
key5: 1998,
key6: +45.122,
key7: -33,
});";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}